Bug 6841 - GSI does not compile with latest openssl
: GSI does not compile with latest openssl
: 4.2.1
: NorduGrid Linux
: P3 blocker
: ---
Assigned To:
: http://www.grid.tsl.uu.se/repos/globu...
: 6896
  Show dependency treegraph
Reported: 2009-08-21 10:07 by
Modified: 2010-02-23 17:51 (History)



You need to log in before you can comment on or make changes to this bug.

Description From 2009-08-21 10:07:30
Building globus-gsi-proxy-ssl with openssl 1.0.0-beta3 (Fedora 12) fails
because the GSI code uses the ASN1_METHOD struct and related functions which
are no longer available in openssl.

From the openssl CHANGES file:

  *) Remove the ancient ASN1_METHOD code. This was only ever used in one
     place for the (very old) "NETSCAPE" format certificates which are now
     handled using new ASN1 code equivalents.

Is anyone working on porting Globus to the new openssl?
------- Comment #1 From 2009-08-21 14:21:21 -------
The linked patch is a workaround for the problem that puts the definitions for
PROXYCERTINFO_asn1_meth() and PROXYPOLICY_asn1_meth() inside a #if
OPENSSL_VERSION_NUMBER < 0x10000000L  ...  #endif conditional.

A grep of the source tree doesn't find anything that uses these functions
within the globus toolkit.
------- Comment #2 From 2009-09-15 10:51:29 -------
Also globus-gsi-credential needs to be patched to compile with openssl 1.0:

------- Comment #3 From 2010-02-23 17:51:01 -------
I've committed these patches and a few others to get GRAM5 working on Fedora
12. Those are committed to the 5.0 branch and trunk.