Bug 6693 - Missing #include in gsi/openssl_module/source/library/globus_openssl.c
: Missing #include in gsi/openssl_module/source/library/globus_openssl.c
Status: RESOLVED FIXED
: GSI C
Authentication
: 4.2.1
: PC Linux
: P3 normal
: 5.0.1
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2009-03-16 09:08 by
Modified: 2010-01-29 14:10 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2009-03-16 09:08:55
The function SSL_library_init() is called in

gsi/openssl_module/source/library/globus_openssl.c

but there is no

#include "openssl/ssl.h"

That provides the definition, so there is a compilation warning about that it
is implicitly defined.
------- Comment #1 From 2010-01-29 14:08:53 -------
*** Bug 6921 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2010-01-29 14:10:04 -------
fix committed to 5.0 branch and trunk