Bug 6388 - CAS assertions don't work with GSI C
: CAS assertions don't work with GSI C
Status: RESOLVED FIXED
: GSI C
Authorization
: 4.2.0
: All All
: P3 major
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-09-16 11:52 by
Modified: 2008-11-13 15:28 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-09-16 11:52:14
The GAA callout code in GT 4.2 doesn't work with CAS assertions generated by
the 4.2 CAS server. 

The CAS server in 4.2 uses DER-encoded assertions using the OID
1.3.6.1.4.1.3536.1.1.1.12, but the callout expects non-DER encoded assertions
using the OID 1.3.6.1.4.1.3536.1.1.1.9.

It appears the new format was introduced in the 4.0.x cycle, with an option to
the 4.0.x cas-proxy-init to use the new format, so this bug can probably be hit
with 4.0 installations as well.
------- Comment #1 From 2008-11-13 15:28:47 -------
Fixed callouts to handle both oids correctly.  Fixes committed to trunk,
globus_4_0_branch and globus_4_2_branch.