Bug 6306 - Improve JNDI Configuration Usability
: Improve JNDI Configuration Usability
Status: RESOLVED FIXED
: Java WS Core
Campaign
: 4.2.0
: Macintosh All
: P3 normal
: 4.2.1
Assigned To:
:
:
:
: 5616
  Show dependency treegraph
 
Reported: 2008-08-14 14:39 by
Modified: 2008-10-02 09:36 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-08-14 14:39:47
Objective: Improve JNDI Configuration Usability

Technologies: Java WS Core

Description:  

The JNDI configuration supported by Java WS Core is extremely verbose and
unclear.  Users defining a configuration need to be intimately aware of the
classes they are configuring and, as a result of no namespace support, get no
assistance from IDE's.  For simple cases, such as those which existed under
previous versions of Java WS Core, this was not much more than a minor
inconvenience, but as components such as JPA and WorkManager require and
support much more configurability, writing a configuration in the old style is
challenging.  This campaign will provide a more domain specific method of
configuring JNDI using namespaces and provide support for component developers
to easily add additional processing rules dynamically.  As a result, service
developers will benefit from both more intuitive configuration, as well as
flexibility to add their own configurable components.

Benefits:

1) Increased usability for service developers.  
2) IDE support will reduce the likelihood of configuration errors.

Implementation tasks: 

1) Expand Commons-Digester's XML configuration support to include namespaces
2) Define appropriate namespaces.
3) Define handlers for processing new namespaces.

Deliverables:

1) Code for processing namespaces
2) Schemas for namespces
3) Passing Unit Tests.
------- Comment #1 From 2008-08-27 14:22:37 -------
*** Bug 6287 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2008-10-02 09:36:17 -------
Code is committed to both trunk and branch and documenation is complete