Bug 6056 - Exception deleting file
: Exception deleting file
Status: RESOLVED FIXED
: RFT
RFT
: development
: Macintosh All
: P3 normal
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-05-01 14:17 by
Modified: 2008-05-01 14:50 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-05-01 14:17:59
While debugging bug #5695 I ran into an RFT exception while cleaning up the
temporary stdout and stderr files. The exception message is 

Error inserting records into database [Caused by: An attempt was made to get a
data value 
of type 'INTEGER' from a data value of type 'null'.]

I'll attach full message longs and exceptions next.
------- Comment #1 From 2008-05-01 14:18:55 -------
Container logs

2008-05-01T15:14:52.155-04:00 INFO 
PersistentManagedExecutableJobResource.e0090d10-17b2-11dd-ad16-88d8754698a1
[ServiceThread-112,start:730] Job e0090d10-17b2-11dd-ad16-88d8754698a1 accepted
for local user 'bester'
2008-05-01T15:14:52.683-04:00 INFO  handler.SubmitStateHandler
[pool-1-thread-1,process:168] Job e0090d10-17b2-11dd-ad16-88d8754698a1
submitted with local job ID 'e04ed106-17b2-11dd-9aea-0017f2cb7d49:23827'
2008-05-01T15:14:55.656-04:00 ERROR factory.ReliableFileTransferFactoryService
[pool-1-thread-1,createReliableFileTransfer:251] Unable to create RFT resource
Error inserting records into database. Caused by SQL Exception: An attempt was
made to get a data value of type 'INTEGER' from a data value of type 'null'.
    at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.EmbedConnection.newSQLException(Unknown
Source)
    at org.apache.derby.impl.jdbc.ConnectionChild.newSQLException(Unknown
Source)
    at
org.apache.derby.impl.jdbc.EmbedPreparedStatement.dataTypeConversion(Unknown
Source)
    at org.apache.derby.impl.jdbc.EmbedPreparedStatement.setObject(Unknown
Source)
    at
org.apache.commons.dbcp.DelegatingPreparedStatement.setObject(DelegatingPreparedStatement.java:165)
    at
org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.storeDeleteRequest(ReliableFileTransferDbAdapter.java:316)
    at
org.globus.transfer.reliable.service.ReliableFileTransferResource.<init>(ReliableFileTransferResource.java:195)
    at
org.globus.transfer.reliable.service.ReliableFileTransferHome.create(ReliableFileTransferHome.java:120)
    at
org.globus.transfer.reliable.service.factory.ReliableFileTransferFactoryService.createReliableFileTransfer(ReliableFileTransferFactoryService.java:243)
    at sun.reflect.GeneratedMethodAccessor456.invoke(Unknown Source)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at
org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:410)
    at
org.globus.axis.providers.RPCProvider.invokeMethodSub(RPCProvider.java:112)
    at
org.globus.axis.providers.PrivilegedInvokeMethodAction.run(PrivilegedInvokeMethodAction.java:47)
    at java.security.AccessController.doPrivileged(Native Method)
    at javax.security.auth.Subject.doAs(Subject.java:396)
    at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:60)
    at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:100)
    at org.globus.axis.providers.RPCProvider.invokeMethod(RPCProvider.java:102)
    at
org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:186)
    at
org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:332)
    at
org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
    at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:454)
    at org.apache.axis.server.AxisServer.invokeService(AxisServer.java:234)
    at org.apache.axis.server.AxisServer.invoke(AxisServer.java:375)
    at org.apache.axis.transport.local.LocalSender.invoke(LocalSender.java:141)
    at
org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
    at org.apache.axis.client.AxisClient.invokeTransport(AxisClient.java:150)
    at org.apache.axis.client.AxisClient.invoke(AxisClient.java:289)
    at org.apache.axis.client.Call.invokeEngine(Call.java:2838)
    at org.apache.axis.client.Call.invoke(Call.java:2824)
    at org.apache.axis.client.Call.invoke(Call.java:2501)
    at org.apache.axis.client.Call.invoke(Call.java:2424)
    at org.apache.axis.client.Call.invoke(Call.java:1835)
    at
org.globus.rft.generated.bindings.ReliableFileTransferFactoryPortTypeSOAPBindingStub.createReliableFileTransfer(ReliableFileTransferFactoryPortTypeSOAPBindingStub.java:1372)
    at
org.globus.exec.service.exec.utils.WSStagingHelper.submitStagingRequest(WSStagingHelper.java:126)
    at
org.globus.exec.service.exec.processing.handler.FileCleanUpStateHandler.process(FileCleanUpStateHandler.java:63)
    at
org.globus.exec.service.exec.processing.handler.InternalStateHandler.processInternalState(InternalStateHandler.java:49)
    at
org.globus.exec.service.exec.processing.StateMachine.processInternalState(StateMachine.java:118)
    at
org.globus.exec.service.exec.processing.StateProcessingTask.run(StateProcessingTask.java:67)
    at
java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:650)
    at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:675)
    at java.lang.Thread.run(Thread.java:613)
2008-05-01T15:14:55.756-04:00 ERROR factory.ReliableFileTransferFactoryService
[pool-1-thread-4,createReliableFileTransfer:251] Unable to create RFT resource
Error inserting records into database. Caused by SQL Exception: An attempt was
made to get a data value of type 'INTEGER' from a data value of type 'null'.
    at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)
    at org.apache.derby.impl.jdbc.EmbedConnection.newSQLException(Unknown
Source)
    at org.apache.derby.impl.jdbc.ConnectionChild.newSQLException(Unknown
Source)
    at
org.apache.derby.impl.jdbc.EmbedPreparedStatement.dataTypeConversion(Unknown
Source)
    at org.apache.derby.impl.jdbc.EmbedPreparedStatement.setObject(Unknown
Source)
    at
org.apache.commons.dbcp.DelegatingPreparedStatement.setObject(DelegatingPreparedStatement.java:165)
    at
org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.storeDeleteRequest(ReliableFileTransferDbAdapter.java:316)
    at
org.globus.transfer.reliable.service.ReliableFileTransferResource.<init>(ReliableFileTransferResource.java:195)
    at
org.globus.transfer.reliable.service.ReliableFileTransferHome.create(ReliableFileTransferHome.java:120)
    at
org.globus.transfer.reliable.service.factory.ReliableFileTransferFactoryService.createReliableFileTransfer(ReliableFileTransferFactoryService.java:243)
    at sun.reflect.GeneratedMethodAccessor456.invoke(Unknown Source)
    at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
    at java.lang.reflect.Method.invoke(Method.java:585)
    at
org.apache.axis.providers.java.RPCProvider.invokeMethod(RPCProvider.java:410)
    at
org.globus.axis.providers.RPCProvider.invokeMethodSub(RPCProvider.java:112)
    at
org.globus.axis.providers.PrivilegedInvokeMethodAction.run(PrivilegedInvokeMethodAction.java:47)
    at java.security.AccessController.doPrivileged(Native Method)
    at javax.security.auth.Subject.doAs(Subject.java:396)
    at org.globus.gsi.jaas.GlobusSubject.runAs(GlobusSubject.java:60)
    at org.globus.gsi.jaas.JaasSubject.doAs(JaasSubject.java:100)
    at org.globus.axis.providers.RPCProvider.invokeMethod(RPCProvider.java:102)
    at
org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:186)
    at
org.apache.axis.providers.java.JavaProvider.invoke(JavaProvider.java:332)
    at
org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
    at org.apache.axis.handlers.soap.SOAPService.invoke(SOAPService.java:454)
    at org.apache.axis.server.AxisServer.invokeService(AxisServer.java:234)
    at org.apache.axis.server.AxisServer.invoke(AxisServer.java:375)
    at org.apache.axis.transport.local.LocalSender.invoke(LocalSender.java:141)
    at
org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
    at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
    at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
    at org.apache.axis.client.AxisClient.invokeTransport(AxisClient.java:150)
    at org.apache.axis.client.AxisClient.invoke(AxisClient.java:289)
    at org.apache.axis.client.Call.invokeEngine(Call.java:2838)
    at org.apache.axis.client.Call.invoke(Call.java:2824)
    at org.apache.axis.client.Call.invoke(Call.java:2501)
    at org.apache.axis.client.Call.invoke(Call.java:2424)
    at org.apache.axis.client.Call.invoke(Call.java:1835)
    at
org.globus.rft.generated.bindings.ReliableFileTransferFactoryPortTypeSOAPBindingStub.createReliableFileTransfer(ReliableFileTransferFactoryPortTypeSOAPBindingStub.java:1372)
    at
org.globus.exec.service.exec.utils.WSStagingHelper.submitStagingRequest(WSStagingHelper.java:126)
    at
org.globus.exec.service.exec.processing.handler.FailureFileCleanUpStateHandler.process(FailureFileCleanUpStateHandler.java:50)
------- Comment #2 From 2008-05-01 14:50:10 -------
This is a dumplicate bug and already fixed in the cvs trunk.