Bug 6040 - updating successful transfers in DB fails with MySQL
: updating successful transfers in DB fails with MySQL
Status: RESOLVED FIXED
: RFT
RFT
: development
: Macintosh All
: P3 blocker
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-04-24 17:49 by
Modified: 2008-04-24 18:37 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-04-24 17:49:00
I get the following error in the container log in jobs with transfers
and MySQL as DB of RFT:

2008-04-24T12:59:07.730-05:00 ERROR service.RFTResourceManager
[Thread-106,transferCompleted:515] Unable to update on finished
org.globus.transfer.reliable.service.database.RftDBException: RFT database
update error [Caused by: You can't specify target table 'transfer' for update
in FROM clause]

Looks like the query in 
ReliableFileTransferDbAdapter.transferCompletedSuccessfully()
causes the problem.

Googled a bit and it seems that nested queries where both queries
work on the same table cause problems with MySQL.

This shows up in the 4.0 branch and in trunk
------- Comment #1 From 2008-04-24 18:37:43 -------
I broke the statement up into 2 statements.  SHould solve the problem