Bug 6039 - maxAttempts == null fails for delete request and derby as DB
: maxAttempts == null fails for delete request and derby as DB
Status: RESOLVED FIXED
: RFT
RFT
: development
: Macintosh All
: P3 blocker
: 4.2
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-04-24 17:40 by
Modified: 2008-04-24 20:02 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-04-24 17:40:36
Submitting a delete-request with maxAttempts not set (i.e. null) causes the
following with derby.

2008-04-24T16:36:33.093-05:00 ERROR factory.ReliableFileTransferFactoryService
[pool-1-thread-10,createReliableFileTransfer:251] Unable to create RFT
resourceError inserting records into database. Caused by SQL Exception: An
attempt was made to get a data value of type 'INTEGER' from a data value of
type 'null'.        at
org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)        at
org.apache.derby.impl.jdbc.Util.newEmbedSQLException(Unknown Source)        at
org.apache.derby.impl.jdbc.Util.generateCsSQLException(Unknown Source)       
at org.apache.derby.impl.jdbc.EmbedConnection.newSQLException(Unknown Source)  
     at org.apache.derby.impl.jdbc.ConnectionChild.newSQLException(Unknown
Source)        at
org.apache.derby.impl.jdbc.EmbedPreparedStatement.dataTypeConversion(Unknown
Source)        at
org.apache.derby.impl.jdbc.EmbedPreparedStatement.setObject(Unknown Source)    
   at
org.apache.commons.dbcp.DelegatingPreparedStatement.setObject(DelegatingPreparedStatement.java:165)
       at
org.globus.transfer.reliable.service.database.ReliableFileTransferDbAdapter.storeDeleteRequest(ReliableFileTransferDbAdapter.java:316)
        at
org.globus.transfer.reliable.service.ReliableFileTransferResource.<init>(ReliableFileTransferResource.java:195)
        at
org.globus.transfer.reliable.service.ReliableFileTransferHome.create(ReliableFileTransferHome.java:120)
        at
org.globus.transfer.reliable.service.factory.ReliableFileTransferFactoryService.createReliableFileTransfer(ReliableFileTransferFactoryService.java:243)
------- Comment #1 From 2008-04-24 20:02:03 -------
Commited patch to trunk