Bug 5872 - Please list the CA filename in the "Could not find CA" error message
: Please list the CA filename in the "Could not find CA" error message
Status: RESOLVED FIXED
: GSI C
Authorization
: unspecified
: Macintosh All
: P3 normal
: 4.0.7
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-02-18 16:14 by
Modified: 2008-08-11 14:50 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-02-18 16:14:01
Given that we know the hash of the CA certificate, could we please list it in
the error message below instead of just saying "Can't get the local trusted CA
certificate" ?  It would be great if it said something like "Can't get trusted
CA certificate for hash d1b603c3".  Bonus points for naming the Trusted CA Cert
dir you were looking in, like "Can't get trusted CA certificate for hash
d1b603c3 in /home/bacon/.globus/certificates"

530-globus_xio: Authentication Error
530-OpenSSL Error: s3_srvr.c:2010: in library: SSL routines, function
SSL3_GET_CLIENT_CERTIFICATE: no certificate returned
530-globus_gsi_callback_module: Could not verify credential
530-globus_gsi_callback_module: Can't get the local trusted CA certificate:
Cannot find issuer certificate for local credential with subject:
/O=Grid/OU=GlobusTest/OU=simpleCA-linux-z38m/CN=host/linux-z38m
530 End.
------- Comment #1 From 2008-02-19 11:21:07 -------
*** Bug 5871 has been marked as a duplicate of this bug. ***
------- Comment #2 From 2008-02-26 13:46:11 -------
Committed the new message to 4.0 branch and trunk.