Bug 5816 - type frees wrong memory
: type frees wrong memory
Status: RESOLVED FIXED
: GSI C
Credentials and Proxies
: 4.0.5
: All All
: P3 minor
: 4.0.7
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-01-25 13:42 by
Modified: 2008-08-11 15:04 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-25 13:42:45
In the function globus_gsi_proxy_handle_set_req, the second if block checks to
see if the handle already contains a request.  In this case, you probably want
to free the old request rather than the new one.

That is,

X509_REQ_free(req);

should be:

X509_REQ_free(handle->req);

This would match the behavior in globus_gsi_proxy_handle_set_private_key

Full disclosure: I just noticed this reading the code; I haven't ever tried to
call this function twice or observed any code that does so and has problems.

Thanks,

-Ian
------- Comment #1 From 2008-01-28 09:29:33 -------
Thanks for the bug report. I don't think anything uses that code path, but it's
clearly wrong. The problem is patched in the 4.0 branch and CVS trunk now.