Bug 5785 - Installer incorrectly sets ssh_config permissions
: Installer incorrectly sets ssh_config permissions
Status: RESOLVED FIXED
: GSI-OpenSSH
GSI-OpenSSH
: 4.0.4
: All Linux
: P3 major
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2008-01-15 04:16 by
Modified: 2008-01-15 09:16 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2008-01-15 04:16:03
This is really about the GTK 4.0.5 installer.
(the Bugzilla "version" menu only goes up to 4.0.4)

The permissions of 
    etc/ssh/ssh_config
are set so that the gsissh client cannot read it.  
(Remember, normally the gsissh client runs as a normal user, rather than
"globus").  

One result is that port settings are ignored.

I have been setting the permissions to a+r, which I think is correct.

This simple little issue has caused us so much grief....
------- Comment #1 From 2008-01-15 07:38:28 -------
Is your umask set to 0027 or 0077 rather than 0022 when you install?
------- Comment #2 From 2008-01-15 08:20:36 -------
I suppose you mean the umask of my 'globus' user, under which the globus on my
desktop machine was installed.

$globus> umask -p
umask 0002

That's curious, since the umask of my normal user is 0022.

But the umask on my system is immaterial. 

This has been observed and complained about by several users on various
systems.

In any case, the GT installer should set the permissions correctly.
------- Comment #3 From 2008-01-15 08:48:48 -------
Thanks for the report.  I can confirm that the permissions were set incorrectly
in the gsi_openssh_setup-4.0 package, included in GT 4.0.5.  The permissions
are set correctly in the latest gsi_openssh_setup-4.2 package, to be included
in GT 4.0.6.
------- Comment #4 From 2008-01-15 09:16:20 -------
Jim,

We eagerly await the new release!