Bug 5614 - Typo in GSI-OpenSSH `configure' for Solaris RPATH string generation --
: Typo in GSI-OpenSSH `configure' for Solaris RPATH string generation --
Status: RESOLVED FIXED
: GSI-OpenSSH
GSI-OpenSSH
: 4.0.4
: Sun Solaris
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-10-12 22:46 by
Modified: 2008-01-10 17:11 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-10-12 22:46:29
This is a duplicate of the bug

 http://bugzilla.ncsa.uiuc.edu/show_bug.cgi?id=374

submitted to the `bugzilla' for the GSI-OpenSSH product but it affects the
`configure' file of all recent GSI-OpenSSH implementations including the one in
gt4.0.5.  Below is a modified copy of the original bug's text.

There's a dollar sign($) missing in the 4.6p1 `configure' code that's used to
generate part of the value for the RPATH string.  A fix for the gt4.0.5 source
is included below.  Without the fix and if the "--with-globus-static"
configure option wasn't specified, the runtime linker is unable to find the GPT
libraries.  This is Solaris specific.  I looked back and found the typo existed
in earlier variants of the GSI-OpenSSH patch and in the gt4.0.5 tarball.

--    Paul Townsend

diff -u
gt4.0.5-all-source-installer/source-trees/gsi_openssh-4.0-src/configure.
ac.orig
gt4.0.5-all-source-installer/source-trees/gsi_openssh-4.0-src/configure.
ac
---
gt4.0.5-all-source-installer/source-trees/gsi_openssh-4.0-src/configure.ac.o
rig     2007-05-02 15:42:29.000000000 -0400
+++ gt4.0.5-all-source-installer/source-trees/gsi_openssh-4.0-src/configure.ac
2007-09-29 04:02:27.671137000 -0400
@@ -1178,7 +1178,7 @@
        fi
        . ./gpt_build_temp.sh
        if test -n "${need_dash_r}"; then
-               GSI_LDFLAGS="-L${gsi_path}/lib -R{gsi_path}/lib"
+               GSI_LDFLAGS="-L${gsi_path}/lib -R${gsi_path}/lib"
        else
                GSI_LDFLAGS="-L${gsi_path}/lib"
        fi
------- Comment #1 From 2007-11-12 16:29:13 -------
Reassigning to the GSI-OpenSSH product.
------- Comment #2 From 2007-11-13 09:14:50 -------
Fix already committed to CVS:
http://www.globus.org/mail_archive/gsi-openssh-commit/2007/10/msg00001.html

Will be in next release.
------- Comment #3 From 2008-01-10 11:27:54 -------
Fixed in gsi_openssh-4.2 released today.

Out of curiosity, is this only an issue if you don't set $LD_LIBRARY_PATH?
------- Comment #4 From 2008-01-10 17:11:52 -------
It could be "resolved" with a LD_LIBRARY_PATH assignment but everyone using the
dynamic library(ies) would have to be aware of that necessity.  Besides, I
personally prefer to not have any need for LD_LIBRARY_PATH since it won't
necessarily be honored if the user is running as root.  Thanks for the upgrade.