Bug 5143 - DONE state never reported for Condor jobs when using Condor-G grid monitor
: DONE state never reported for Condor jobs when using Condor-G grid monitor
Status: RESOLVED FIXED
: GRAM
gt2 Gatekeeper/Jobmanager
: 4.0.3
: All All
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2007-03-22 18:41 by
Modified: 2012-09-12 10:42 (History)


Attachments
Patch to fix double-counting of condor log events (247 bytes, patch)
2007-03-22 18:42, Jaime Frey
Details


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2007-03-22 18:41:15
There's a bug in the poll() function of condor.pm, the Condor interface perl
module of GRAM. It doesn't affect the job-manager, but it does affect
Condor-G's Grid Monitor. If all jobs are sharing the same Condor user job log
and the last event is a terminated event, that event can end up being
double-counted across multiple calls to poll(). If the number of terminated
events is greater than the gram job count, then poll() returns ACTIVE instead
of DONE.

The problem is that $record is not declared to be locally scoped in poll(), so
its contents are preserved from one call to poll() to another. I will attache a
patch.
------- Comment #1 From 2007-03-22 18:42:12 -------
Created an attachment (id=1218) [details]
Patch to fix double-counting of condor log events
------- Comment #2 From 2007-03-22 18:43:58 -------
The VDT is unaffected by this bug, as it uses a separate Condor user log for
each job, as outlined in bugzilla ticket 4199.