Bug 4850 - RFT didn't retry on Idle Timeout during GSSAPI authentication
: RFT didn't retry on Idle Timeout during GSSAPI authentication
Status: RESOLVED FIXED
: RFT
RFT
: 4.0.3
: PC Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2006-11-08 13:25 by
Modified: 2008-03-17 15:56 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2006-11-08 13:25:43
On a heavily loaded machine, I had the following error:

[jbasney@dg-011 ~]$ cat rft.xfer 
true
16000
16000
false
1
true
1
null
null
false
10
gsiftp://dg-011.ncsa.uiuc.edu:2811/etc/group
gsiftp://dg-011.ncsa.uiuc.edu:2811/tmp/rftTest_Done.tmp
[jbasney@dg-011 ~]$ rft -h $HOSTNAME -f rft.xfer
Number of transfers in this request: 1
Subscribed for overall status
Termination time to set: 60 minutes

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
0/0/1/0/0
Error:Error authenticating user at source/dest hostServer refused performing
the request. Custom message: Server refused GSSAPI authentication. (error code
1) [Nested exception message:  Custom message: Unexpected reply: 421 Idle
Timeout: closing control connection.] [Caused by: Server refused performing the
request. Custom message: Server refused GSSAPI authentication. (error code 1)
[Nested exception message:  Custom message: Unexpected reply: 421 Idle Timeout:
closing control connection.]]
All Transfers failed !

I had the maximum number of retries set to 10, but RFT didn't appear to retry. 
When I run it again, it succeeds:

[jbasney@dg-011 ~]$ rft -h $HOSTNAME -f rft.xfer
Number of transfers in this request: 1
Subscribed for overall status
Termination time to set: 60 minutes

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
0/1/0/0/0

 Overall status of transfer:
Finished/Active/Failed/Retrying/Pending
1/0/0/0/0
All Transfers are completed
------- Comment #1 From 2008-03-17 15:56:40 -------
This should be fixed in 4.0.7