Bug 3500 - ServiceGroupRegistrationClient.terminate( ) failure
: ServiceGroupRegistrationClient.terminate( ) failure
Status: RESOLVED FIXED
: MDS4
wsrf_servicegroup
: 4.0.0
: All All
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-06-20 08:36 by
Modified: 2005-07-20 16:43 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-06-20 08:36:27
Please set this.initialized=true in the last line of the following method of 
ServiceGroupRegistrationClient:

public void register(ServiceGroupRegistrationParameters params, long delayMillis)


The problem is that the "initialized" state is not properly set when registrations are added 
programmatically, later causing the terminate( ) method to return prematurely when invoked.

I wasn't sure if you'd mind me changing code, so I'm submitting a bug instead.
------- Comment #1 From 2005-06-20 19:37:27 -------
I've committed code to CVS trunk to address this.  The initialized checks have 
been removed altogether.
------- Comment #2 From 2005-07-20 16:43:30 -------
Fixed for 4.0.1