Bug 3412 - Staging delegation host address needs to use logical host name
: Staging delegation host address needs to use logical host name
Status: RESOLVED DUPLICATE of bug 3132
: Delegation Service
Delegation Service
: unspecified
: Other AIX
: P3 major
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-05-25 10:52 by
Modified: 2005-05-31 11:47 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-05-25 10:52:42
I am able to run a simple fork or LSF type jobs with globusrun-ws, but  when
using
staging/streaming  the credential delegation service errors due to the target
address not being what was expected in the stagingDelegationFactoryEndpoint.

Cleanup is having this problem with  the host address . Apparently not using
the logicalHost of the container . My hostname and container logicalHost were
not the same.  Hostname was "f3n2e.....",  later  I set logicalHost  in the
globus_wsrf_core/server-config.wsdd after I installed GT4 to the name which
a remote client  will  use.   Here is the error:

    Destroying job...Done.
    Cleaning up any delegated credentials...Done.
    globusrun-ws: Job failed: Staging error for RSL element fileCleanUp.

    ; nested exception is:
            org.globus.common.ChainedIOException: Authentication failed [Caused
by: org.ietf.jgss.GSSException, major code: 15, minor code: 25
            major string: Operation unauthorized
            minor string: Authorization failed. Expected
"/CN=host/f3n2e.fnmoc.navy.mil" target but received "/C=US/O=U.S.
Government/OU=DoD/OU=PKI/OU=USN/CN=amsdc2b.fnmoc.navy.mil"]


I expected to get the same hostname (or ip address ) used in   the ws address
for delegationFactoryEndpoint and stagingDelegationFactoryEndpoint , but
instead  I get the container logicalHost  in the first, and the original
hostname  in the
second.  

Should the stagingDelegationFacrotyEndpiont be using the logicalHost  that  I
have specified in
globus_wsrf_core/server-config.wsdd   ?   What means can be used to reconfigure
this?

Here is the  response shown by "globusrun-ws -dbg" showing the different 
addresses:


<soapenv:Body>delegationFactoryEndpoint
   <GetMultipleResourcePropertiesResponse          
xmlns="http://docs.oasis-open.org/wsrf/2004/06/wsrf-WS-ResourceProperties-1.2-draft-01.xsd">
            <ns1:delegationFactoryEndpoint
xmlns:ns1="http://www.globus.org/namespaces/2004/10/gram/job">

<wsa:Address>https://152.80.57.236:8443/wsrf/services/DelegationFactoryService</wsa:Address>
                <wsa:ReferenceProperties/>                
<wsa:ReferenceParameters/>            </ns1:delegationFactoryEndpoint>         
  <ns2:stagingDelegationFactoryEndpoint
xmlns:ns2="http://www.globus.org/namespaces/2004/10/gram/job">

<wsa:Address>https://f3n2e.fnmoc.navy.mil:8443/wsrf/services/DelegationFactoryService</wsa:Address>
                 <wsa:ReferenceProperties/>
                 <wsa:ReferenceParameters/>

</ns2:stagingDelegationFactoryEndpoint></GetMultipleResourcePropertiesResponse>
</soapenv:Body>
------- Comment #1 From 2005-05-25 11:05:21 -------
The endpoint is constructed in the GRAM code AFAIK. I am going to wait for GRAM 
folks to comment on this before investigating of the delegation service code.
------- Comment #2 From 2005-05-26 14:52:48 -------
 In etc/gram-service/jndi-config.xml, the pararmeter value for stagingHost
was changed to the same value used for the logicalHost, now it works.
------- Comment #3 From 2005-05-31 11:47:56 -------
I'm marking this as a duplicate of bug 3132 since this should not be an issue
once that is fixed and 
because this clearly has a workaround.

*** This bug has been marked as a duplicate of 3132 ***