Bug 3077 - Issues with globus-credential-delegate and globus-credential-refresh
: Issues with globus-credential-delegate and globus-credential-refresh
Status: RESOLVED FIXED
: Delegation Service
Delegation Service
: 3.9.5
: Other Linux
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-04-05 08:22 by
Modified: 2005-05-03 17:06 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-04-05 08:22:19
The following are two issues related to globus-credential-delegate 
and ./bin/globus-credential-refresh

In GT3.9.5 documentation for globus-credential-delegate mentions about
 -o <filename> Filename to write out EPR of delegated credential.

The Help for command globus-credential-delegate  is not mentioning about -o 
option.
But the command accepts the file with and without -o.

ie ./bin/globus-credential-delegate -o mycred and 
./bin/globus-credential-delegate  mycred is possible.
If its an expected behaviour, please update the Help for the command as well 
as the documentation.


The second thing is , for ./bin/globus-credential-refresh, the file that 
contains delegation credential EPR,     defaults to delegatedCredEPR.

The ./bin/globus-credential-delegate is not providing a facility to store the 
epr to default file, say delegatedCredEPR.

But if we wont mention a epr file to ./bin/globus-credential-refresh, its 
always looking for delegatedCredEPR.
------- Comment #1 From 2005-04-05 09:51:50 -------
Fixed the documents for the first part. Any resolution for second part will be 
an interface change, stalled till 4.0 is released.
------- Comment #2 From 2005-04-05 22:46:04 -------
*** Bug 3085 has been marked as a duplicate of this bug. ***
------- Comment #3 From 2005-04-06 02:45:20 -------
I have seen the changes(exclusion of -o option) in the documentation.
But the command accepts the -o option as a valid one.
------- Comment #4 From 2005-04-06 08:53:33 -------
The command line has been fixed to parse through valid options and then read 
the next argument as filename. Arguments after that are ignored.

Thanks,
Rachana
------- Comment #5 From 2005-05-03 17:06:13 -------
Fix committed to trunk. A filename to write the delegated resource EPR is 
required now. Also, the refresh client does not default to any file and 
requires a filename to read EPR from (using -e option).