Bug 2581 - NPE in DelegationResource
: NPE in DelegationResource
Status: RESOLVED FIXED
: Delegation Service
Delegation Service
: unspecified
: All All
: P3 normal
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2005-01-19 11:24 by
Modified: 2005-01-19 11:58 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2005-01-19 11:24:46
2005-01-19 11:12:29,584 ERROR delegation.DelegationUtil
[Thread-13,getDelegationResource:254] Error getting delegation resource
org.globus.wsrf.ResourceException: Failed to load resource; nested exception is: 
        java.lang.NullPointerException
        at
org.globus.delegation.service.DelegationResource.load(DelegationResource.java:412)
        at
org.globus.wsrf.impl.ResourceHomeImpl.createNewInstanceAndLoad(ResourceHomeImpl.java:236)
        at org.globus.wsrf.impl.ResourceHomeImpl.get(ResourceHomeImpl.java:271)
        at org.globus.wsrf.impl.ResourceHomeImpl.find(ResourceHomeImpl.java:256)
        at org.globus.delegation.service.DelegationHome.find(DelegationHome.java:47)
        at
org.globus.delegation.DelegationUtil.getDelegationResource(DelegationUtil.java:252)
        at
org.globus.delegation.DelegationUtil.registerDelegationListener(DelegationUtil.java:167)
        at
org.globus.exec.service.utils.DelegatedCredential.getDelegatedCredential(DelegatedCredential.java:136)
        at
org.globus.exec.service.utils.DelegatedCredential.getDelegatedCredential(DelegatedCredential.java:67)
        at
org.globus.exec.service.job.ManagedJobResourceImpl.getStagingCredential(ManagedJobResourceImpl.java:387)
        at
org.globus.exec.service.exec.ManagedExecutableJobResource.setStagingStubSecurity(ManagedExecutableJobResource.java:1393)
        at
org.globus.exec.service.exec.StateMachine.submitStagingRequest(StateMachine.java:1895)
        at
org.globus.exec.service.exec.StateMachine.processStageOutState(StateMachine.java:1303)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at
org.globus.exec.service.exec.StateMachine.processState(StateMachine.java:258)
        at org.globus.exec.service.exec.RunQueue.run(RunQueue.java:93)
Caused by: java.lang.NullPointerException
        at
org.globus.delegation.service.DelegationResource.setResourceDescriptor(DelegationResource.java:316)
        at
org.globus.delegation.service.DelegationResource.initialize(DelegationResource.java:129)
        at
org.globus.delegation.service.DelegationResource.load(DelegationResource.java:410)
        ... 18 more
------- Comment #1 From 2005-01-19 11:58:40 -------
Apparenly GRAM attempts to access the credential from a thread with which 
Message Context is not associated. Committed a work around.