Bug 1927 - authz linking problems on Mac OS X
: authz linking problems on Mac OS X
Status: RESOLVED FIXED
: GSI C
Authorization
: development
: Macintosh MacOS
: P3 blocker
: ---
Assigned To:
:
:
:
:
  Show dependency treegraph
 
Reported: 2004-09-14 13:40 by
Modified: 2008-08-11 14:45 (History)


Attachments


Note

You need to log in before you can comment on or make changes to this bug.


Description From 2004-09-14 13:40:54
It looks like libglobus_gsi_authz_callout_error is built as module for 
dlopening, but we are trying to link directly against it. Pieces of the build 
log: 
 
*** Warning: Linking the shared library 
    libglobus_authz_gaa_callout_gcc32dbg.la against the loadable module 
*** libglobus_gsi_authz_callout_error_gcc32dbg.so is not portable! 
** Warning, lib libglobus_gsi_authz_callout_error_gcc32dbg.so is 
   a module, not a shared library 
... 
ld: /sandbox/rynge/autotools-test-builds/200409141110/packaging/gt3.9.2rc3-wsrf-source-installer/test-install/lib/libglobus_gsi_authz_callout_error_gcc32dbg.so 
is input for the dynamic link editor, is not relocatable by the 
static link editor again 
make[2]: *** [libglobus_authz_gaa_callout_gcc32dbg.la] Error 1
------- Comment #1 From 2004-09-16 15:39:33 -------
This looks like it was built by mistake with -module instead of -shared. Not
sure why configure would 
want to do that. I'll see if I can look at it on the plane
------- Comment #2 From 2004-09-16 15:53:31 -------
I have been told that this library is only supposed to be dlopened and that 
-module is right. If that is the case, the problem is in the GPT dependency 
declarations. 
 
------- Comment #3 From 2004-09-21 07:54:20 -------
Ok, if it is going to dynamically opened by dyld, it needs to be of type
MH_BUNDLE, so compiling with 
-bundle is correct. 
------- Comment #4 From 2004-12-07 18:34:59 -------
I fixed this a while ago.  That lib is just a utility lib that could be linked 
in as a shared lib wherever it was needed.  It'll be in 3.9.4.

Mike